Tienda Wifi

Tienda Wifi
CiudadWireless es la tienda Wifi recomendada por elhacker.NET

Buscador

Entradas Mensuales

Suscripción

¿Quieres recibir las últimas novedades del blog en tu correo?

¡Suscríbete al feed!

Foro de elhacker.net - Noticias

elhacker.NET en Facebook

Entradas populares

PostHeaderIcon Encuentra paquetes vulnerables en Arch Linux con Arch-audit




Arch-audit es una nueva utilidad para sistemas Arch Linux, que nos permite identificar que paquetes instalados en nuestro sistemas que sean vulnerables a un determinado problema de seguridad. Arch-audit sería la utilidad equivalente a pkg-audit en sistemas FreeBSD.





El programa se basa en el trabajo del Arch CVE Monitoring Team, un equipo de la distro encargado de estar al tanto de los avisos de seguridad, reportar vulnerabilidades y mantener el contacto con los desarrolladores para su resolución lo antes posible. Siempre hablando de software que esté incluido en los repositorios oficiales (Core, Extra y Community)


Lo que arch-audit hace como programa, es confrontar los paquetes instalados en nuestro sistema con la base de datos de CVE (Common Vulnerabilities and Exposures). Esta última se trata de la principal referencia a la hora de clasificar e identificar amenazas cibernéticas, incluyendo su descripción, enlaces de interés y posible asignación para su resolución.

Dependencias:

  • alpm = "^0.2"
  • curl = "^0.3"
  • env_logger = "^0.3"
  • log = "^0.3"
  • json = "^0.10"
  • select = "^0.3"

Instalación:

git clone https://github.com/ilpianista/arch-audit
cd arch-audit
cargo build
cargo run


La ejecución del programa es muy sencilla:

arch-audit


A continuación nos aparecerá la lista de paquetes vulnerables, con el número de CVE correspondiente y sugiriendo en algunos casos la actualización a una nueva versión.

$ arch-audit
Package wpa_supplicant is affected by ["CVE-2016-4477", "CVE-2016-4476"]. VULNERABLE!
Package libtiff is affected by ["CVE-2015-7554", "CVE-2015-8683"]. VULNERABLE!
Package openssl is affected by ["CVE-2016-2177", "CVE-2016-2178", "CVE-2016-2179", "CVE-2016-2180", "CVE-2016-2181", "CVE-2016-2182", "CVE-2016-2183", "CVE-2016-6302", "CVE-2016-6303", "CVE-2016-6304", "CVE-2016-6306"]. Update to 1.0.2.i-1!
Package linux is affected by ["CVE-2016-5244", "CVE-2016-5243"]. VULNERABLE!
Package crypto++ is affected by ["CVE-2016-7420"]. VULNERABLE!
Package xerces-c is affected by ["CVE-2015-0252"]. Update to 3.2.1-1!
Package giflib is affected by ["CVE-2015-7555"]. Update to 5.2.1-1!
Package jasper is affected by ["CVE-2015-5203"]. VULNERABLE!
Fuente:
http://lamiradadelreplicante.com/2016/09/23/arch-audit-comprobacion-de-vulnerabilidades-de-software-en-arch-linux/

0 comentarios :

Publicar un comentario

Los comentarios pueden ser revisados en cualquier momento por los moderadores.

Serán publicados aquellos que cumplan las siguientes condiciones:
- Comentario acorde al contenido del post.
- Prohibido mensajes de tipo SPAM.
- Evite incluir links innecesarios en su comentario.
- Contenidos ofensivos, amenazas e insultos no serán permitidos.

Debe saber que los comentarios de los lectores no reflejan necesariamente la opinión del STAFF.